tipc network layer · Maintained
Maintainers
- M Jon Maloy <jmaloy@redhat.com>
Paths
- F
include/uapi/linux/tipc*.h - F
net/tipc/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-crypto (capped at 30), ordered by date desc.
-
STALE88d
[PATCH 07/11] net: tipc: Use crypto_stdrng_get_bytes()
2026-03-26 · Eric Biggers <ebiggers@kernel.org> -
STALE273d
[PATCH RFC 005/104] crypto: hide crypto_default_rng variable
2025-09-04 · Vegard Nossum <hidden> -
STALE1098d
LANDED [PATCH net-next v5 15/16] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-23 · David Howells <dhowells@redhat.com> -
STALE1102d
[PATCH net-next v4 14/15] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-23 · David Howells <dhowells@redhat.com> -
STALE1102d
[PATCH 09/11] sysctl: Remove the end element in sysctl table arrays
2023-06-21 · Joel Granados <hidden> -
STALE1088d
[PATCH net-next v3 17/18] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-20 · David Howells <dhowells@redhat.com> -
STALE1105d
[PATCH net-next v2 16/17] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-17 · David Howells <dhowells@redhat.com> -
STALE1108d
[PATCH net-next 16/17] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-16 · David Howells <dhowells@redhat.com> -
STALE1159d
[PATCH v3 55/55] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-31 · David Howells <dhowells@redhat.com> -
STALE1172d
[RFC PATCH v2 48/48] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-29 · David Howells <dhowells@redhat.com> -
STALE1192d
[RFC PATCH 1/3] net: Drop the size argument from ->sendmsg()
2023-03-22 · David Howells <dhowells@redhat.com> -
STALE1192d
[RFC PATCH 28/28] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-03-16 · David Howells <dhowells@redhat.com> -
STALE1236d
[PATCH 7/17] tipc: Add scaffolding to change completion function signature
2023-02-06 · "Herbert Xu" <herbert@gondor.apana.org.au> -
STALE1236d
[PATCH 15/17] tipc: Remove completion function scaffolding
2023-02-06 · "Herbert Xu" <herbert@gondor.apana.org.au> -
STALE1320d
REVIEWED: 18 (18M) [PATCH v3 1/3] treewide: use get_random_u32_below() instead of deprecated function
2022-11-17 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1320d
REVIEWED: 18 (18M) [PATCH v2 1/3] treewide: use get_random_u32_below() instead of deprecated function
2022-11-14 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1322d
[PATCH v1 1/5] treewide: use get_random_u32_below() instead of deprecated function
2022-10-22 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1351d
REVIEWED: 28 (27M) [PATCH v6 1/7] treewide: use prandom_u32_max() when possible, part 1
2022-10-10 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1359d
REVIEWED: 2 (1M) [PATCH v5 1/7] treewide: use prandom_u32_max() when possible, part 1
2022-10-08 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1360d
REVIEWED: 2 (1M) [PATCH v4 1/6] treewide: use prandom_u32_max() when possible, mechanically
2022-10-07 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1360d
REVIEWED: 2 (1M) [PATCH v3 1/5] treewide: use prandom_u32_max() when possible
2022-10-06 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1362d
REVIEWED: 3 (2M) [PATCH v2 1/5] treewide: use prandom_u32_max() when possible
2022-10-06 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1356d
[PATCH v1 1/5] treewide: use prandom_u32_max() when possible
2022-10-06 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1575d
[PATCH 6/6] treewide: remove check of list iterator against head past the loop body
2022-02-28 · Jakob Koschel <hidden> -
STALE2151d
[PATCH 25/26] net: pass a sockptr_t into ->setsockopt
2020-07-23 · Christoph Hellwig <hch@lst.de> -
STALE2168d
[PATCH 24/24] net: pass a sockptr_t into ->setsockopt
2020-07-20 · Christoph Hellwig <hch@lst.de> -
STALE2204d
REVIEWED: 19 (19M) [PATCH v5 2/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2203d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2205d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE3056d
[PATCH 8/8] net: tipc: remove unused hardirq.h
2017-11-17 · Yang Shi <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE88d
[PATCH 07/11] net: tipc: Use crypto_stdrng_get_bytes()
2026-03-26 · Eric Biggers <ebiggers@kernel.org>